• Регистрация

yum не устанавливает пакеты "Error: Multilib version problems found..."

0 голосов
24,640 просмотров

При выполнении yum update выдает такое:

Loaded plugins: fastestmirror, replace, security
Loading mirror speeds from cached hostfile
 * base: mirror.logol.ru
 * epel: mirror.logol.ru
 * epel-testing: mirror.logol.ru
 * extras: mirror.logol.ru
 * remi: mirror.awanti.com
 * remi-test: mirror.awanti.com
 * rpmforge: ftp.colocall.net
 * updates: mirror.logol.ru
Setting up Update Process
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package libproxy-python.x86_64 0:0.3.0-3.el6_3 will be updated
--> Processing Dependency: libproxy-python = 0.3.0-3.el6_3 for package: libproxy-0.3.0-3.el6_3.x86_64
---> Package libproxy-python.x86_64 0:0.3.0-4.el6_3 will be an update
--> Finished Dependency Resolution
Error: Package: libproxy-0.3.0-3.el6_3.x86_64 (@anaconda-CentOS-201303020151.x86_64/6.4)
           Requires: libproxy-python = 0.3.0-3.el6_3
           Removing: libproxy-python-0.3.0-3.el6_3.x86_64 (@anaconda-CentOS-201303020151.x86_64/6.4)
               libproxy-python = 0.3.0-3.el6_3
           Updated By: libproxy-python-0.3.0-4.el6_3.x86_64 (base)
               libproxy-python = 0.3.0-4.el6_3
 You could try using --skip-broken to work around the problem
** Found 10 pre-existing rpmdb problem(s), 'yum check' output follows:
chkconfig-1.3.49.3-2.el6_4.1.x86_64 is a duplicate with chkconfig-1.3.49.3-2.el6.x86_64
db4-4.7.25-18.el6_4.x86_64 is a duplicate with db4-4.7.25-17.el6.x86_64
krb5-libs-1.10.3-10.el6_4.6.x86_64 is a duplicate with krb5-libs-1.10.3-10.el6.x86_64
...
module-init-tools-3.9-21.el6_4.x86_64 is a duplicate with module-init-tools-3.9-21.el6.x86_64
 
 
При запуске yum-complete-transaction
 
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.logol.ru
 * epel: mirror.logol.ru
 * epel-testing: mirror.logol.ru
 * extras: mirror.logol.ru
 * remi: mirror.awanti.com
 * remi-test: mirror.awanti.com
 * rpmforge: ftp.colocall.net
 * updates: mirror.logol.ru
Checking for new repos for mirrors
There are 1 outstanding transactions to complete. Finishing the most recent one
The remaining transaction had 174 elements left to run
Package libproxy-0.3.0-4.el6_3.x86_64 already installed and latest version
...
Package setup-2.8.14-20.el6_4.1.noarch already installed and latest version
--> Running transaction check
---> Package bash.x86_64 0:4.1.2-14.el6 will be erased
---> Package bind-utils.x86_64 32:9.8.2-0.17.rc1.el6_4.6 will be installed
--> Processing Dependency: bind-libs = 32:9.8.2-0.17.rc1.el6_4.6 for package: 32:bind-utils-9.8.2-0.17.rc1.el6_4.6.x86_64
---> Package chkconfig.x86_64 0:1.3.49.3-2.el6 will be erased
...
---> Package nss-softokn-freebl.i686 0:3.14.3-9.el6 will be installed
--> Finished Dependency Resolution
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
 
         1. You have an upgrade for bind-libs which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of bind-libs of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude bind-libs.otherarch ... this should give you an error
            message showing the root cause of the problem.
 
         2. You have multiple architectures of bind-libs installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
 
         3. You have duplicate versions of bind-libs installed already.
            You can use "yum check" to get yum show these errors.
 
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
 
       Protected multilib versions: 32:bind-libs-9.8.2-0.17.rc1.el6_4.6.i686 != 32:bind-libs-9.8.2-0.23.rc1.el6_5.1.x86_64
 You could try using --skip-broken to work around the problem
** Found 11 pre-existing rpmdb problem(s), 'yum check' output follows:
bash-4.1.2-15.el6_4.x86_64 is a duplicate with bash-4.1.2-14.el6.x86_64
...
module-init-tools-3.9-21.el6_4.x86_64 is a duplicate with module-init-tools-3.9-21.el6.x86_64
 
 
 
спросил 24 Март, 14 от vadim s. sabinich (5,440 баллов)

1 Ответ

0 голосов

лечится следующим образом:

удаляем конфликтующие пакеты с отключением возможности удаления по зависимостям:

  • rpm --erase --nodeps <PKG-NAME>

и производим его последующую установку

  • yum install <PKG-NAME>

На примере ошибки:

** Found 10 pre-existing rpmdb problem(s), 'yum check' output follows:
chkconfig-1.3.49.3-2.el6_4.1.x86_64 is a duplicate with chkconfig-1.3.49.3-2.el6.x86_64
 
Выполняем такие шаги:
-bash-4.1# rpm --erase --nodeps chkconfig-1.3.49.3-2.el6_4.1.x86_64
-bash-4.1# rpm --erase --nodeps chkconfig-1.3.49.3-2.el6.x86_64
-bash-4.1# yum install chkconfig
 
 
ответил 24 Март, 14 от vadim s. sabinich (5,440 баллов)
редактировать 24 Март, 14 от vadim s. sabinich
есть шанс нарваться на то, что может быть удалена какой-либо файл библиотеки, требуемый для работы того же yum ;)
Если не удалять оба пакета, то никаких тяжелых последствий возникнуть не должно.
...